使用rvm,homebrew或macports编译ruby 1.9.3时出错

我尝试使用rvm安装 ruby 1.9.3,使用自制程序,并使用macports,所有似乎都在编译过程中失败.我正在使用Lion OSX.

这是我最近尝试使用rvm的日志文件

http://pastebin.com/AEiJbGzD

任何帮助,将不胜感激.这一切都是在我开始遇到openssl错误时开始的,所以尝试卸载openssl并重新安装它. Openssl安装没有问题,但后来我无法重新安装ruby.

谢谢

我可以使用带有–with-gcc = clang标志的rvm在Lion和Xcode 4.2上安装Ruby 1.9.3:

$rvm install 1.9.3 --with-gcc=clang
相关文章
相关标签/搜索
天空彩票与你同行 香港 小说